News

Our templates and extensions are compatible to Joomla 3.7.

Sat May 6, 2017 7:02 am
We are glad to inform you that all current version of our Joomla! 3 - templates and extensions are fully compatible to latest Joomla v3.7.

Feel free update your site if you are using the latest versions of our products. If you are using any older version of our products then please update them to their respective latest versions before updating Joomla.
Post your reviews about us on our Facebook Page.
Post your testimonials and suggestions Here.
Don't forget to Close your topic when resolved.

 The following users say thank you to Jumbo for this post: silvanus, goldlink

The topic has been locked.