Closed

No correct image on sharing to facebook

Mon Sep 5, 2022 2:23 pm
Hi the plugin seems to put the correct image in the metatags but facebook does not take it:
geosism.com/geosism-blog/terricci-substr...e-e-bene-utilizzarla
Attachments:
The topic has been closed.
Mon Sep 5, 2022 8:13 pm
You have another extension installed, adding Open Graph Meta tags above the meta tags added by VM OG Meta Tag Plugin. Therefore, Facebook is ignoring the meta tags added by the plugin. You need to disable the additional extension to allow VM OG Meta Tag Plugin to work properly. See the attached screenshot for reference.


2022-09-05-vm-og-meta-tags.png
Post your reviews about us on our Facebook Page.
Post your testimonials and suggestions Here.
Don't forget to Close your topic when resolved.
The topic has been closed.
Mon Sep 5, 2022 9:21 pm
Thanks, I found that the template despite the option was disabled kept entering them in the page as if it were a bug, I worked around the problem by disabling the layout and now in the page source there are no longer only those of VM-OG-METATAGS but if I share on facebook the wrong image is always taken is there anything else I should do?
The topic has been closed.
Mon Sep 5, 2022 9:38 pm
I tested the page with three different Open Graph Meta Tag checker tools, and they all show the correct image as per the proper meta tags.

www.opengraph.xyz
smallseotools.com/open-graph/
metatags.io/

You can also test the page yourself using these tools.

I think it is a cache issue with the Facebook shares, which should get resolved over time.
Post your reviews about us on our Facebook Page.
Post your testimonials and suggestions Here.
Don't forget to Close your topic when resolved.
The topic has been closed.
Mon Sep 5, 2022 9:43 pm
Ok thanks I saw, then I have to think that it is a cache of my facebook app I just have to wait for it to empty, again thanks
The topic has been closed.
Mon Sep 5, 2022 9:45 pm
You can also contact Facebook Developer support by creating a Developer account for your site. developers.facebook.com
Post your reviews about us on our Facebook Page.
Post your testimonials and suggestions Here.
Don't forget to Close your topic when resolved.
The topic has been closed.
Tue Sep 6, 2022 4:23 pm
Hello, however if I use the facebook tool developers.facebook.com/tools/debug any url of the site geosism.com/geosism-blog the image tag is never taken and the sharing is never the one provided by the tags and we cannot understand why, what can be the cause ? it appears that the metatags on the page are being ignored
The topic has been closed.
Wed Sep 7, 2022 11:12 am
There must be some issues with the site. You have already checked that the meta tags are added correctly to the site. Since Facebook does not consider those tags, you should contact Facebook support for an explanation, as mentioned earlier.
Post your reviews about us on our Facebook Page.
Post your testimonials and suggestions Here.
Don't forget to Close your topic when resolved.
The topic has been closed.
Thu Oct 6, 2022 5:11 pm
Hello, i still have the problem and i don't understand the cause but after insisting with the assistance i got an answer from which i quote (translated into english):
"Alex Smith Meta team
Hi John,
thank you for contacting us with the problem and information in screencast.
So, we checked the link in the sharing debugger tool. We have the same problem that you encountered, which is that the images are changed after scraping.
You can solve this problem by placing these tags at the beginning of the HTML HEAD tag, because FB loads them starting from the first 50 kb. If they are loaded later, then this error can occur!

I am attaching some related documents that may come in handy with the information:
developers.facebook.com/docs/sharing/webmasters/images/
developers.facebook.com/docs/sharing/web...s/images/#precaching
developers.facebook.com/docs/sharing/webmasters#markup
developers.facebook.com/docs/sharing/webmasters#media

Hope this can help you.
With regard, Alex "

now how do i go about moving the metatags to the beginning of the <head> tag?
an example of where the plugin inserts them in the page source:
geosism.com/geosism-blog/bonsai/119-cicl...tilizzo-dei-prodotti
The topic has been closed.
Thu Oct 6, 2022 8:37 pm
The plugin does not have any option to change the location of the meta tags. The meta matgs are added to the site using a core Joomla method \Joomla\CMS\Document\HtmlDocument::addCustomTag. You can refer to this official Joomla API documentation to learn more - api.joomla.org/cms-3/classes/Joomla.CMS....nt.HtmlDocument.html. Joomla places all the custom tags after existing script tags.

An optimisation extension can reduce the number of tags and their sizes. Example: JCH Optimize
Post your reviews about us on our Facebook Page.
Post your testimonials and suggestions Here.
Don't forget to Close your topic when resolved.
The topic has been closed.